Hyundai Santa Cruz Forum banner
81 - 96 of 96 Posts

·
Registered
Black Limited
Joined
·
261 Posts
those are the ones that I ordered a couple of weeks ago. They do work and you don’t get any errors, but I could hear the fan noise inside the cabin. The fan starts operating when the LED reach a certain temperature. For me, after holding the brake for around 5-7 seconds, I could hear the cooling fans. I returned them. Let me know if you experience the same thing.
WOW! Got mine installed and didn't notice anything until I backed into the garage. Shut the truck off and opened the door. Thought to myself funny... wonder why there are sirens running on such a nice day as it is today. Then I took my foot off the brake and the sirens stopped! Yep, guess I'll be sending these back too...
 

·
Registered
Black Limited
Joined
·
261 Posts
WOW! Got mine installed and didn't notice anything until I backed into the garage. Shut the truck off and opened the door. Thought to myself funny... wonder why there are sirens running on such a nice day as it is today. Then I took my foot off the brake and the sirens stopped! Yep, guess I'll be sending these back too...
Well, installed my third set of bulbs today. Now, I'm back to the incandesent bulbs. Just tired of fighting the LED errors and don't want big resistors spliced in or bouncing around, getting good and hot tucked in by other wiring. Such is life... went full circle.
 

·
Registered
Joined
·
89 Posts
WOW! Got mine installed and didn't notice anything until I backed into the garage. Shut the truck off and opened the door. Thought to myself funny... wonder why there are sirens running on such a nice day as it is today. Then I took my foot off the brake and the sirens stopped! Yep, guess I'll be sending these back too...
Yeah, I figured that you were going to hear the fan noise. I received my third set yesterday. So far, no errors, but I had to use a screwdriver to extend the metal contact inside the socket so it could make a solid connection with the bulb.
 

·
Registered
Black Limited
Joined
·
261 Posts
Yeah, I figured that you were going to hear the fan noise. I received my third set yesterday. So far, no errors, but I had to use a screwdriver to extend the metal contact inside the socket so it could make a solid connection with the bulb.
Which ones are you trying now? I hate the incandesent bulbs I put back in. :confused:
 

·
Registered
Joined
·
89 Posts
I says cannot be used as turn signal
It says this also:
  • ★【Long-life Turn Signal Light】 Made of 46pcs high quality 3020 SMD chips and premium quality aluminum alloy, good heat dissipation, …….
I installed them on Wedenesday. So far, no issues. Maybe it doesn’t work on some vehicles, but at least for me, it works on the SC.
 

·
Registered
2022 Ultimate, Sage Grey, Dark Green two-tone leather
Joined
·
139 Posts
It says this also:
  • ★【Long-life Turn Signal Light】 Made of 46pcs high quality 3020 SMD chips and premium quality aluminum alloy, good heat dissipation, …….
I installed them on Wedenesday. So far, no issues. Maybe it doesn’t work on some vehicles, but at least for me, it works on the SC.
They are white correct. How do they look compared to other red ones
 

·
Registered
Black Limited
Joined
·
261 Posts
the red ones I got are 1156, at least that is what the box say. I guess they sold out. I was wondering how different would be with the white ones.
1157 (dual filament) wouldn't work in a 1156 (single filament) socket, so you got 1156. Would rather have red for the deeper color since the LEDs are plenty bright enough as is. Just feed up with error codes.
 

·
Registered
Joined
·
78 Posts
Very pissed about the Formula J87 lights from eBay. Four bulbs (left right brake turn) within 2 days ALL triggering canbus alarms. Super annoying.
Vendor has suggested adding resistors. Ummm... isn't that the point of buying canbus compatible lights in the first place?
So in 10 degF freezing cold, and 20mph winds, at night, I put in old style filament light bulbs. All canbus errors clear. It's the LEDs, not the SC.
 

·
Registered
2022 SEL Premium Black
Joined
·
16 Posts
Very pissed about the Formula J87 lights from eBay. Four bulbs (left right brake turn) within 2 days ALL triggering canbus alarms. Super annoying.
Vendor has suggested adding resistors. Ummm... isn't that the point of buying canbus compatible lights in the first place?
So in 10 degF freezing cold, and 20mph winds, at night, I put in old style filament light bulbs. All canbus errors clear. It's the LEDs, not the SC.
I think several of us here have proven that these J87 bulbs are not up to the task.
 
81 - 96 of 96 Posts
Top