Hyundai Santa Cruz Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So we got our new SEL on Saturday (9/18) and apple car play worked from the test drive until today (9/20) it stopped working. Reset phone, head unit, Bluetooth, everything I could think of with no luck. Bluetooth connects to the phone but apple car play won't. This appears to be a issue with other Hyundai's. Hs anyone experienced this or know of a fix?
 

·
Registered
2022 Hyundai Santa Cruz SEL Premium AWD 2.5T Blue Stone
Joined
·
186 Posts
Mine stopped working a few days after ownership. I had pulled into a convenience store with it connected, and left the motor running with my wife in the passenger seat while I went inside to get snacks. When I came back out, CarPlay was disconnected, but the phone was still connected via Bluetooth. So I'm able to make/take calls, but don't have CarPlay functionality. I'm ok with that, as I hated how CarPlay hijacked the infotainment system when I'd first get into the car. I want to listen to SiriusXM, and CarPlay kept taking over, so I'd have to select Radio multiple times until CarPlay would give up. And if I wanted to play Pokemon GO, the app audio would take over, even with audio turned off in the app. Now it behaves normally. I'll probably check it later to make sure that it's just CarPlay turned off, and not some other issue.
 

·
Registered
Phantom Black Limited AWD
Joined
·
144 Posts
Look for Phone Projection on the settings of your vehicle.
Make sure Apple Car Play is activated.
Once on, you should be able to reconnect your phone.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Leaving the car off for an hour, disconnecting and forgetting everything and resetting the head unit, then reconnecting everything seems to have worked for now. I had tried that all before, the only difference now was leaving the car off for an hour. I'll cross my fingers and update if it continues to happen.
 

·
Registered
2022 Santa Cruz - Blue Stone / SEL Premium
Joined
·
33 Posts
Had and am having a similar issue. From what I gathered on Tucson forums, the connection issues came about as Apple released more recent updates. I have been able to fix 90% of my issues by resetting the head unit as you described. Small little hiccup in connection here and there but not much. We’ll see how my ios 15 update goes. Crossing my fingers it’s flawless.
 
1 - 6 of 6 Posts
Top