Hyundai Santa Cruz Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi everyone,

I just picked up my SEL Premium yesterday, and after driving around for a bit both yesterday and this morning, I've noticed that the temp gauge does not settle on the midpoint of the gauge, it's slightly on the Cold side, even after over 30 min of driving. I'll post a picture later today if I remember to take one, but I was curious if this is normal behavior or if this is just me.

I'm used to driving E46 BMWs....so I'm used to paying attention to the temp gauge, lol. I know temp gauges are usually buffered anyway, but not being in the center worries me. This kind of behavior makes me worried that my thermostat might already be sticking.
 

·
Registered
2022 Sage Grey SC Ultimate
Joined
·
1,313 Posts
Depends on the vehicle. On our Equinox normal operating temp is a bit over 1/3, never seen it hit halfway. Our Journey sits around halfway. My old truck isn't really buffered and I can see exactly when the thermostat opens and closes.
 

·
Registered
2022 SEL AWD * Non-Activity - SoCal
Joined
·
1,689 Posts
Are you sure that is displaying engine temp? At less than 1,000RPM that looks more like oil pressure to me. Just saying. 🤔
 

·
Registered
2022 SEL AWD * Non-Activity - SoCal
Joined
·
1,689 Posts
It is engine (water/coolant) temp for sure, look at the icon.
Oh! At the bottom of the tach. Yes, temp. I was looking at the blue bar bottom center. I guess that might be average MPG of 23.6 and the bar moves in realtime? I hate these digital flat screens! Sorry, but I do. No worries if you like them though, it's MY problem.
 

·
Registered
Joined
·
1,881 Posts
I guess that might be average MPG of 23.6 and the bar moves in realtime?
Correct.

And I love the digital dash in my C7. Its way more customizable with lots of data (oil temp, transmission temp, etc) in comparison the SC is bare bones with its party trick being the blind spot camera display.
 

·
Registered
22 SC SEL AWD activity package, '21 Chevrolet 3500HD Duramax
Joined
·
457 Posts
Got a picture for anyone else wondering. Seems like it must be pretty normal then for the SC. Weird that I've never seen this in any other vehicle I've owned (and I've owned quite a few)....but guess I won't worry too much about it.
View attachment 2574
I have the NA 2.5 SEL and that is exactly where my temp reads all the time.
 
1 - 19 of 19 Posts
Top